Red X for images or attachments in a Word Export

By Jama posted 01-29-2015 19:17

  

There are several areas you can check if you are getting a red X in place of images with Word exports. The following troubleshooting steps should be followed in order until the issue is resolved. Note that step 2 is not applicable if you are using Jama 8.x.

1. Base URL: If you recently migrated or changed the URL to your Jama Instance, chances are, you will need to change the base URL. You can do this as the root
user under Organizations > Change URL.

2. Enhanced Image Security: Enabling this option will require users to log in before viewing an image from a link. To disable enhanced image security, log in as root and select 'No' under System Properties > General Properties > Enhanced Image Security. Verify if you can then see the images. 

3. SSL: 

2015.5 and prior: If you have connected Jama using an SSL certificate, you must configure Java to store that certificate. When running exports, we pass the images or attachments to Java in the form of a URL. Java then requests that URL from Tomcat. Since Tomcat or a proxy in front of Tomcat is configured to require a certificate, Java must have this certificate stored in order to get images. To store this certificate with Java, you must import it into the cacerts file. Instructions on how to do this can be found here.

8.x: Instructions for setting up an SSL Cert can be found in this article.

4. Proxies: If the above steps do not work, and you are behind a proxy, run the following curl command from the application server to see if the request is being rerouted:
curl -v -k [image URL]

You can find the image URL from within the application by right-clicking on the image and selecting Copy Image URL. If there is anything before that URL such as 'folder/file.jsp?retURL=' or something similar, then it means your URL is passing through something else that is not allowing the image to pass through. If this is the case then contact your network administrator with the output of the call, and let them know this needs to be allowed. 

5. Contact Support: If the above fails, submit a ticket.



#OfficeTemplates
7 comments
189 views

Comments

05-09-2016 22:24

Yay! It's great to receive that confirmation.

05-09-2016 18:12

We are not seeing this issue in the Jama8 release. Will consider it solved for our issue with Jama8 Release.

04-22-2016 18:44

Agreed making a SHA2 work is the best step. Let me know if I should open support ticket or just work it thru community.

04-22-2016 17:18

Nick, I checked in with Shabnam and she said that SHA2 should work currently. I noticed you commented on Iris' article about adding an SSL certificate. Troubleshooting that issue would probably be best with the SHA2 certificate since that's what you really want to use.

04-21-2016 23:38

Thanks for update. We are using SHA2 as well. I will try SHA1 cert. Is jama going to address this issue with SHA2 certs will become mandatory?

04-02-2015 22:30

That is a very helpful tip! Thanks for sharing it.

04-02-2015 20:11

Just another note on how i fixed my issue.  We were using the new certificates(sha2) which will be mandatory in 2018.  I had to downgrade my certificate to(sha1) in order for Jama to work with this issue.