View Only

ReadMe for 8.49.x Installs

By Kristina King posted 11-10-2020 14:58


Note: the following article is irrelevant if you upgrade to 8.49.3 rather than to the .1 or .2 patches. However, we are keeping this article up in case you run into one of these issues.

The patches for Jama Connect Self-Hosted 8.49 introduced some security updates, so we recommend upgrading to 8.49.2 if you are on 8.49.0. (8.49.2 supplanted 8.49.1.) There are some special steps you need to take if Jama Connect is installed on a Red Hat environment, if you access Jama Connect via a proxy, or if you are using Jama Connect Self-Hosted Airgap. Note that if you are currently on 8.49.0 and plan to upgrade to 8.56.0 shortly, moving to 8.49.2 is not necessary. 

Red Hat Docker Install Issue

The script that we provide on our Community can not upgrade Docker on RHEL distributions. This is because Red Hat Linux no longer supports Docker 18.09, so the script fails when attempting to upgrade Docker 18.09 via Linux repos. You will see an error that the Docker Repo and mirrors could not be reached while running the install script. You will need to manually install Docker 19.03.  

Example error:

Trying other mirror.
One of the configured repositories failed (Docker main Repository),
and yum doesn't have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work "fix" this:
1. Contact the upstream for the repository and get them to fix the problem.
2. Reconfigure the baseurl/etc. for the repository, to point to a working
upstream. This is most often useful if you are using a newer
distribution release than is supported by the repository (and the
packages for the previous distribution release still work).
3. Run the command with the repository temporarily disabled
yum --disablerepo=docker-main-repo ...
4. Disable the repository permanently, so yum won't use it by default. Yum
will then just ignore the repository until you permanently enable it
again or use --enablerepo for temporary usage:
yum-config-manager --disable docker-main-repo
or subscription-manager repos --disable=docker-main-repo
5. Configure the failing repository to be skipped, if it is unavailable.
Note that yum will try to contact the repo. when it runs most commands,
so will have to try and fail each time (and thus. yum will be be much
slower). If it is a very temporary problem though, this is often a nice
yum-config-manager --save --setopt=docker-main-repo.skip_if_unavailable=true
failure: repodata/0615103afda1f7dfe0638913d6c66d2a52f0e2b15bb4f5a80f9b609d098a6639-filelists.sqlite.bz2 from docker-main-repo: [Errno 256] No more mirrors to try. [Errno 14] HTTPS Error 404 - Not Found

How to Fix It

1. Get the install .rpm from here:

You can download it via a browser and copy it to the server, or you can use wget on the server to download it directly. 

2. Install Docker 19.03

sudo yum localinstall

3. Start the Docker service 

systemctl start docker  

4. Run the install script as you normally would just skip the Docker install 

Airgap/Proxied Network Connection Refused Issue

The second issue affects Airgapped users and users in proxied environments. The issue is that the Replicated and Replicated-Operator config files are not updated correctly during the upgrade. We are now setting these to use the docker0 address rather than the public address that we used to set up. 

You will see "connection refused" errors in the UI and the logs after the upgrade. 

How to Fix It

1. Get the docker0 ip address 

ifconfig docker0

You need the inet address. In this case, it is 

2. Get the jamacore IP address 

sudo docker ps | grep coreIn this example, it is

3. Edit the Replicated file. 

  • On Debian and Ubuntu systems this file is located in /etc/default/
  • On RHEL and yum based systems it is located in /etc/sysconfig/
  • Cat the file located at /etc/default/replicated

The file should look something like this:


Set the PRIVATE_ADDRESS= the docker0 IP 

If you have troubles with this, contact your IT team or server administrator.

4. Edit the replicated-operator file 

  • On Debian and Ubuntu systems this file is located in /etc/default/
  • On RHEL and yum based systems it is located in /etc/sysconfig/
  • Cat the file located at /etc/default/replicated-operator

The file should look something like this: 


set DAEMON_ENDPOINT= the docker0 IP:9879
set DAEMON_HOST=the docker0 IP
set PRIVATE_ADDRESS=the docker0 IP
set PUBLIC_ADDRESS=the jamacore IP

5. Restart the Replicated Services 

sudo systemctl restart replicated
sudo systemctl restart replicated-operator 

6. Restart Jama from the Admin Console



12-17-2020 15:45

@Victor Cheung Thank you so much for sharing what you found! We do have plenty of other customers on RHEL, so this is great information to share. I'm sorry you ran into (yet another...) issue getting Jama installed on Red Hat.

And credit for this guide goes to my teammate @Jason Ritz who spent a ton of time figuring this pickle out.

12-17-2020 11:15

Thank you for putting this guide together, Kristina.  Really helpful for Jama instances installed on RHEL since there seems to be always technical surprises when needing to upgrade Docker and/or Replicated on RHEL.

I just wanted to share our own experience upgrading to Docker 19.03 manually (from 17.05.0-ce) on RHEL 7.1 in case this may be helpful for others.  I ran into various errors during this process, but in the end, these are the steps that worked:

  1. stop Jama (from Admin console)
  2. stop Replicated (sudo systemctl stop replicated replicated-ui replicated-operator)
  3. stop Docker (sudo systemctl stop docker)
  4. uninstall Docker (sudo yum remove docker\*)
  5. download Docker 19.03 install file (sudo wget
  6. download Docker 19.03 install dependency file 1 (sudo wget
  7. download Docker 19.03 install dependency file 2 (sudo wget
  8. install Docker 19.03 install dependency file 1 (sudo yum localinstall docker-ce-cli-19.03.9-3.el7.x86_64.rpm)
  9. install Docker 19.03 install dependency file 2 (sudo yum localinstall
  10. install Docker 19.03 install file (sudo yum localinstall docker-ce-19.03.9-3.el7.x86_64.rpm)
  11. start Docker (systemctl start docker)