Support

Expand all | Collapse all

Jama Review comment box "Red Border" error (SOS-DEF-105)

  • 1.  Jama Review comment box "Red Border" error (SOS-DEF-105)

    Posted 10-27-2016 17:13
    During a spec review, I can make comments and submit.  After a certain amount of time, after I type in a comment in a comment box, the comment box gets a red border.  When this occurs, the submit button no longer works.  From here I can no longer add comments to any spec.  Only way to resolve is to log out of Jama and log back in.  What causes this issue?

    https://d2r1vs3d9006ap.cloudfront.net/s3_images/1502310/RackMultipart20161027-17828-1cddjw0-Jama_comment_box_red_border_inline.png?1477588365" />


  • 2.  Re: Jama Review comment box "Red Border" error (SOS-DEF-105)

    Posted 10-27-2016 21:03
    Hi Jim, what browser are you using? If using IE, this is a known issue, logged as SOS-DEF-105. Generally speaking clearing the cache prevents this from occurring. However, we haven't determined what causes it, as we have not been able to reproduce it consistently.


  • 3.  Re: Jama Review comment box "Red Border" error (SOS-DEF-105)

    Posted 10-27-2016 21:25

    Hi Kristina.  Thanks for the info.  I am using IE11.  I will switch to Chrome or Firefox and see if the problem occurs there.



  • 4.  Re: Jama Review comment box "Red Border" error (SOS-DEF-105)

    Posted 10-28-2016 08:16
    Hi Guys,


    FYI, we're seeing this regularly in Chrome with 2015.5. Kristina, would it be possible to post a listing of the bug data that Jama has? We're not sure what causes it.


    Cheers,

    Grant


  • 5.  Re: Jama Review comment box "Red Border" error (SOS-DEF-105)

    Posted 10-28-2016 16:15
    We're not sure what's causing it either, Grant. Thanks for reporting that it's also happening on Chrome, though. :/ Here's what we've got for the bug: Issue:

    Randomly in the Review Center, a user is stopped from replying to an existing comment because the comment box turns red when hitting submit. It thinks the submit button was already pressed with no text in the box when clearly, there is text within the box. 

    Steps to Reproduce:

    1. Have a Moderator reply to many comments within a Review

    2. Edit Items within a Review and reply to comments there too

    3. Basically reply to comments every way possible

     Results:

    Eventually, the user will experience the red line around the comment box and will no longer be able to comment.

    Expected Results:

    The comment box recognized the text that has been typed and allows to be submitted

     Workaround:

    A couple of things have cleared this issue:

     -resfresh browser

    -Clear browser cache

    -logout of session, close the browser and log back in

    -other times the issue doesn't reappear for users

    Notes:

    Browser console does not produce any errors when red box is seen. Was able to produce it once but after the browser refresh I was unable to trigger it again.

    Another engineer tested this using seven user accounts: 1 creator account created the review. Used a collaborator, stakeholder and reviewer with RW permissions. Used a collaborator, stakeholder and reviewer with RO permissions. Each type of user made their own comments, replied to comments from the others, approved comments. They all approved the review, created another rev and tried again. Did the same thing where they all said the review needs more work. No luck reproducing.


  • 6.  Re: Jama Review comment box "Red Border" error (SOS-DEF-105)

    Posted 10-28-2016 16:29
    Thanks Kristina! Hope you're well! :)

    /G


  • 7.  Re: Jama Review comment box "Red Border" error (SOS-DEF-105)

    Posted 11-01-2016 17:22

    Been using Google Chrome for about 4 days now and no Red Box.  Will report back after a few weeks of use.



  • 8.  Re: Jama Review comment box "Red Border" error (SOS-DEF-105)

    Posted 11-02-2016 12:09
    Hi Guys,

    Apologies, correction! After double-checking, our affected users are using IE (despite being told to use Chrome!) and hence we HAVE NOT seen this issue on Chrome.

    Sorry for the confusion!

    Cheers,
    Grant


  • 9.  Re: Jama Review comment box "Red Border" error (SOS-DEF-105)

    Posted 11-02-2016 16:57
    Well, that's reassuring! Thanks for following up, Grant.


  • 10.  RE: Re: Jama Review comment box "Red Border" error (SOS-DEF-105)

    Posted 06-14-2019 10:55
    Our customer is hitting this error in Chrome as well. Is there an update on this fix?
    We are having them try the workaround, but as a result of their frustration they will not use the Review Center.

    ------------------------------
    Elizabeth Rosenberg
    Alight Solutions
    ------------------------------



  • 11.  RE: Re: Jama Review comment box "Red Border" error (SOS-DEF-105)

    Posted 26 days ago

    Hi Elizabeth:

    If you are having this same issue in Chrome (not Internet Explorer), I would suggest putting in a ticket with our Support team so they can test and try to recreate and then possibly put in for a new defect.

    Best,



    ------------------------------
    Chloe Elliott
    Jama Software
    Portland OR
    ------------------------------