Support

Expand all | Collapse all

Docker version requirements?

  • 1.  Docker version requirements?

    Posted 04-18-2016 14:33
    The overview of the dockerized Jama distribution model at https://community.jamasoftware.com/jama/topics/jama-on-premises-update-technical-overview states that the new model should work on "any version of Linux that supports docker-engine 1.6 or better". However, the beta seems to require version 1.10 or better:

    This installer will upgrade your current version of Docker (1.7.1) to the minimum required version: 1.10.2
    Do you want to allow this? (Y/n) n

    This is from a machine running RHEL 7.1, with which Red Hat currently provides docker v.1.7.1.

    Are there specific aspects of docker v1.10 that the beta requires (e.g. docker volume, docker network), or is replicated.com just requiring this version because that's what they happened to test with themselves?

    In any case, should the requirements in the above community posting be updated to clarify the later version of docker required? This may influence the decisions of customers who may wish to only use RHEL packages supported by the OS vendor (Red Hat).


  • 2.  Re: Docker version requirements?

    Posted 04-18-2016 14:38
    Hi Ryan,

    First of all, thank you for this feedback.  I will circle back with some clarity on this subject shortly.


  • 3.  Re: Docker version requirements?

    Posted 04-18-2016 15:52
    Hi Ryan,

    Currently Replicated supports versions 1.7.1 - 1.10.3 of docker. You will not lose functionality by utilizing 1.7.1. There have been some major improvements to docker itself since 1.7.1 but Replicated will not be effected.  The installer will continue if you select "n" to upgrading Docker.  I will have our documentation updated to reflect this information as well.  Thank you again for the feedback and let us know if you have any other questions or concerns.


  • 4.  Re: Docker version requirements?

    Posted 04-18-2016 16:06
    Thanks, Troy -- the installer seems to terminate if I say no:

    > curl -sSL https://get.replicated.com">https://get.replicated.com">https://get.replicated.com | sudo sh
    Does this machine require a proxy to access the Internet? (y/N) n
    This installer will upgrade your current version of Docker (1.7.1) to the minimum required version: 1.10.2
    Do you want to allow this? (Y/n) n
    Please manually upgrade your current version of Docker to the minimum required version: 1.10.2

    >


  • 5.  Re: Docker version requirements?

    Posted 04-18-2016 17:25
    Hi Ryan,

    Unfortunately I did speak too soon and also confirmed the same.  I can now say that this functionality will be added to the install script to allow a range of supported docker versions.  The docker version is pinned in the install script.  Rather than piping the script to the shell, download the script, edit the pinned version variable as shown below then execute the script.  This is a workaround for now as this will become a feature for cases like this.

    PINNED_DOCKER_VERSION='1.7.1'

    Let me know if you have any questions or concerns.


  • 6.  RE: Re: Docker version requirements?

    Posted 01-25-2017 02:01
    Hi,

    we have installed Jama behind a proxy, which means that we have installed docker manually.
    The installed version is 1.12.3 which was the recommended version by the time of installation.
    Docker has released an upgrade recently, which means that the current version if docker is 1.13.0
    We have set the 1.12.3 version of docker to "hold", which means that docker is currently not upgraded even when doing "apt-get upgrade".

    What we would like to be sure of:
    - Is the way of holding on to a supported version the right way for now?
    - Is Jama evaluating the issues of newer docker versions?
    - If there are security-related fixes in the upgraded versions of Jama - will Jama give recommendations on upgrading?

    Thank you,
    Anna

    ------------------------------
    Anna Henke
    MeVis BreastCare GmbH & Co. KG
    ------------------------------



  • 7.  RE: Re: Docker version requirements?

    Posted 01-25-2017 16:58
    Hi Anna,
    I'm working on getting an answer for you.

    ------------------------------
    Kristina King
    Jama Software
    ------------------------------



  • 8.  RE: Re: Docker version requirements?

    Posted 01-27-2017 09:57
    Hi Anna,

    I wanted to address your questions and concerns.

    - Is it possible to retain the version of Docker that is installed, and is this supported?
    First, disable the Docker repo. In the repo config file there is a line for enabled=1. 1 enables automatic updates to Docker. Zero will disable system updates. Unless an issue is discovered which is resolved by a Docker upgrade (very unlikely), we will support this holding method.

    - Is Jama evaluating the issues of newer Docker versions?
    Jama relies primarily on the Replicated infrastructure. Replicated performs the QA on newer versions of Docker.

    - If there are security-related fixes in the upgraded versions of Jama - will Jama give recommendations on upgrading Docker?
    We will publish recommendations for upgrading Replicated and Docker in Jama’s release notes.

    Best Regards,



    ------------------------------
    Troy Knutson
    Jama Software
    ------------------------------