Support

Expand all | Collapse all

Relationship building

  • 1.  Relationship building

    Posted 26 days ago
    Production 8.31.1
    TEST 8.36.0

    Functionality is the same in both Production and Test environment; configuring in Chrome.

    While trying to relate two items, i potentially found a gap in functionality and need assistance in determining whether this is a bug, or by design.

    Example 1: Relating 2 like items by opening item 1 > Click on Relationship widget > Click search > Search code > zero results
    step 1: No upsteam/downstream
    step1step 2: Search my second code "V5140" - returns zero results
    step2

    Example 2: "Check-mark" item 1 within list view > Click Actions > "Relate to Existing" > Search Code > Returns results

    step 1
    step1astep 2: search code
    step2a
    step 3: relationship built
    step3
    Can you provide any logic into why the first way did not work?

    ------------------------------
    Laura Cornelison
    System Administration
    Providence Health Plan
    Beaverton OR
    ------------------------------


  • 2.  RE: Relationship building

    Posted 24 days ago
    Hi Laura,

    This behavior is a known defect, SOS-DEF-2264: "Relate to Existing" from list/reading views allows one to break relationship rules. The correct behavior is what you see in Single Item View, so we suggest mentioning to your users to relate items from Single Item View.

    I went ahead and related your Organization and this post to SOS-DEF-2264 in our internal tracking system. When reviewing the Release Notes, keep an eye out for this ID to know when it's been fixed.

    Thanks Laura!

    ------------------------------
    Kimberly Embry
    ------------------------------