Support

Expand all | Collapse all

Odd behavior in Trace View

  • 1.  Odd behavior in Trace View

    Posted 08-10-2018 12:08
    Hi Jama -
    I'm using 8.25 and I've noticed some odd behavior in Trace View. Sometimes when I select a saved view the list is blank:
    Blank Trace View
    The column heading "Source" says there are 73 items - where are they?
    If I refresh the screen using the browser refresh or by traversing up the relationship path the data appears but the columns are the default ones and not the ones I saved with the view:
    Trace View Wrong Columns
    On the Source side a custom field should be displayed instead of Description. On the "1 Level Downstream" side Description should not be displayed.

    Does this behavior sound incorrect or am I doing something wrong? If it's a bug is there an existing defect or should I submit one?

    Thanks,

    ------------------------------
    Theresa
    Fujifilm SonoSite
    WA United States
    ------------------------------


  • 2.  RE: Odd behavior in Trace View

    Posted 08-13-2018 11:18
    Theresa:

    Thank you for your questions. I have been attempting to recreate this in my instance, and have not been able so far. You mentioned that this happens "Sometimes", I'm curious if you have noticed that this tends to happen in a particular browser? Or within a particular project?

    What you are seeing with the Traceview column configuration is intriguing. So, from what I understand you are using the "Change Columns" to change the view of each individual downstream and upstream columns but, then whenever you refresh (due to the weirdness of the view turning up blank in the first place), it goes back to default? So you are using these to create your view correct? (See orange circles): 
    Also, are you noticing this when the Trace View comes up populated (as design) or only when you are dealing with the fore-mentioned issue?

    The question "The column heading "Source" says there are 73 items - where are they?" - from the picture it looks like you could scroll down and view more "Sources". Let me know if you aren't able to scroll or if there just aren't any more items in that column.

    Thank you for your added information here, I will keep attempting to recreate what you are seeing, I just wanted to double check that I am fully understanding what your experience is.

    Best,



    ------------------------------
    Chloe Elliott
    Jama Software
    ------------------------------



  • 3.  RE: Odd behavior in Trace View

    Posted 08-13-2018 15:54
    Hi Chloe -
    I am able to recreate the "blank list" issue today. See my responses to your questions below.

    You mentioned that this happens "Sometimes", I'm curious if you have noticed that this tends to happen in a particular browser? [tls - I only use Chrome] Or within a particular project?  [tls - I mostly work in one Project. We are just starting to use Jama and don't have much data in other projects.]

    What you are seeing with the Traceview column configuration is intriguing. So, from what I understand you are using the "Change Columns" to change the view of each individual downstream and upstream columns but, then whenever you refresh (due to the weirdness of the view turning up blank in the first place), it goes back to default?  [tls - Yes. Notice that when the list is blank there are no column headings displayed.] So you are using these to create your view correct? (See orange circles):
     [tls - Yes]

    Also, are you noticing this when the Trace View comes up populated (as design) or only when you are dealing with the fore-mentioned issue?  [tls - I think only when I'm dealing with the other issue too, but I'll pay more attention.]

    The question "The column heading "Source" says there are 73 items - where are they?" - from the picture it looks like you could scroll down and view more "Sources". Let me know if you aren't able to scroll or if there just aren't any more items in that column.  [tls - When the list looks blank there aren't any items even if I scroll down.]

    Thanks,

    Theresa Soares

    Verification and Validation Engineer III, System Verification
    FUJIFILM SonoSite, Inc.
    theresa.soares@fujifilm.com
    www.sonosite.com

    425.442.1523 mobile


    NOTICE:  This message, including any attachments, is only for the use of the intended recipient(s) and may contain confidential, sensitive and/or privileged information, or information otherwise prohibited from dissemination or disclosure by law or regulation, including applicable export regulations.  If the reader of this message is not the intended recipient, you are hereby notified that any use, disclosure, copying, dissemination or distribution of this message or any of its attachments is strictly prohibited.  If you received this message in error, please contact the sender immediately by reply email and destroy this message, including all attachments, and any copies thereof.





  • 4.  RE: Odd behavior in Trace View

    Posted 08-14-2018 10:12
    Theresa:

    Alright, I have been playing in Traceview and have a few more questions and possibilities. My first question is have you saved your view after you changed the fields?


    I found that before I "saved" my view I could make my settings disappear too, but only if I refreshed the whole Chrome browser. When I refreshed within Jama, my settings stayed.

    Once you configure and save the view, you should be able to access it like so:


    My next question is: have you periodically cleared your Chrome cache? I am thinking this could be what is hindering the missing Source column items. Chrome is great, but it is notorious for it's greedy cache. I would periodically go into Chrome > Preferences > Settings (hamburger) > Advanced > Privacy and Security > Clear Browsing Data > choose a timeframe - (longer than the default hour) > clear. (Notice the long file path).

    Sidebar: I love developing small apps using Chrome Dev tools but, I noticed early on that the more I worked in Chrome the more it would cache older versions of my program therefore making any additions and changes not show up in the browser. Refreshing the cache can help.

    Theresa, let me know if any of these options make sense for you. If you are having these issues with a "saved traceview", please let me know so we can trouble shoot further.

    Best,

    ------------------------------
    Chloe Elliott
    Jama Software
    ------------------------------