Support

Expand all | Collapse all

Report paramter "Review" not working

  • 1.  Report paramter "Review" not working

    Posted 11-12-2019 00:04
    Edited by Anna Henke 11-12-2019 00:04
    Hi,

    we noticed that in Jama 8.42 when adding the "Review" report parameter to a velocity script that it will not show the available reports of the project the report is executed in.
    If this is a reproducible behaviour on your side please let us know the issue-number.

    Thank you,
    Anna

    ------------------------------
    Anna Henke
    MeVis BreastCare GmbH & Co. KG
    ------------------------------


  • 2.  RE: Report paramter "Review" not working

    Posted 11-12-2019 08:34
    Anna:

    When you make that ticket with Support, please add this in as well!

    Thank you,

    ------------------------------
    Chloe Elliott
    Jama Software
    Portland OR
    ------------------------------



  • 3.  RE: Report paramter "Review" not working

    Posted 11-15-2019 00:43
    we have the same issue? Any idea when a fix will be available?

    ------------------------------
    Matt Heger
    Munich
    ------------------------------



  • 4.  RE: Report paramter "Review" not working

    Posted 11-15-2019 08:49
    Edited by Chloe Elliott 11-15-2019 08:49
    Matt and Anna:

    I am working on getting answers for you on this subject. I will circle back once I have more information for you!

    Best,​

    ------------------------------
    Chloe Elliott
    Jama Software
    Portland OR
    ------------------------------



  • 5.  RE: Report paramter "Review" not working

    Posted 11-18-2019 01:23

    Hi everyone,

    It seems that the following criteria are needed so that the Reviews are visible in the picklist:

    - The user executing the report must be the moderator of the Review
    - The Review must not be archived

    If both criteria are met, the review is displayed in the list.
    At least the first criterion seems to be a little too restrictive...

    Regards
    Anna



    ------------------------------
    Anna Henke
    MeVis BreastCare GmbH & Co. KG
    ------------------------------



  • 6.  RE: Report paramter "Review" not working

    Posted 11-18-2019 10:20
    Anna:

    Great, thanks for coming back to the thread and completing the circle!

    Best,

    ------------------------------
    Chloe Elliott
    Jama Software
    Portland OR
    ------------------------------



  • 7.  RE: Report paramter "Review" not working

    Posted 11-19-2019 01:58
    Hi Chloe,
    well - I think my last comment explains how Jama currently behaves... but I am not sure if this is the intended/useful behaviour. I would expect that at least all participants of a review (or even all users, in case of public reviews) should be able to access the list.
    Regards
    Anna

    ------------------------------
    Anna Henke
    MeVis BreastCare GmbH & Co. KG
    ------------------------------