Support

Expand all | Collapse all

Diagram Editor not fully WYSIWYG

  • 1.  Diagram Editor not fully WYSIWYG

    Posted 02-16-2018 09:52
    Version: Jama 8.4.2
    Build date: 2016/09/26 11:59

    Browser: Google Chrome Version 61.0.3163.100 (Official Build) (64-bit)

    Diagrams drawn using the embedded diagram editor have a different final aspect than what is shown in the editor. See attached image for the different rendering illustrations.


    ------------------------------
    Sophie Marini
    Mercury Systems, Inc
    ------------------------------


  • 2.  RE: Diagram Editor not fully WYSIWYG

    Posted 02-16-2018 18:24
    Hello Sophie,
    I have successfully reproduced this behavior in version 8.4.2 and in version 8.24.1 (newest).  If I am unable to find a current defect for this I will create a new one. I'll keep you posted. Thank you.

    ------------------------------
    Dana Medhaug
    Technical Support Engineer
    Jama Software
    ------------------------------



  • 3.  RE: Diagram Editor not fully WYSIWYG

    Posted 02-20-2018 11:07
    Hi,

    I've just come across another annoying behavior of the Diagram Editor: if I hit CTRL+S while I am working in the editor window, it will save my work and close the window. I've developed the habit of hitting CTRL+S regularly without thinking about it from working within the Microsoft ecosystem and it kind of interrupts my flow when it just goes off and close my work instead of silently saving it in the background like I expect it to.

    Best regards,

    ------------------------------
    Sophie Marini
    Mercury Systems, Inc
    ------------------------------



  • 4.  RE: Diagram Editor not fully WYSIWYG

    Posted 02-20-2018 15:58
    Hi Sophie,
    I could definitely see how this would get annoying and interfere with your workflow. This would be more of a Feature Request then a defect. I would encourage you to post a new feature request for this.

    ------------------------------
    Dana Medhaug
    Technical Support Engineer
    Jama Software
    ------------------------------



  • 5.  RE: Diagram Editor not fully WYSIWYG

    Posted 29 days ago
    Hi,
    is there any update of this bug (we are on Jama 8.20.2)
    I think it is very annoying that the diagrams you create differ between the in-editor view and the output in jama (especially if linebreaks are added unintentionally).
    Thank you.

    ------------------------------
    Sebastian Merz
    Requirements Engineer
    Sick AG
    ------------------------------



  • 6.  RE: Diagram Editor not fully WYSIWYG

    Posted 25 days ago
    Hello Sebastian,
    The issue @Sophie was experiencing is a known bug (SOS-DEF-1773) that is still present in the latest version of Jama Connect. Are you experiencing the same issue or something different? If it is a different issue a screenshot would be helpful for troubleshooting. Thank you.

    ------------------------------
    Dana Medhaug
    Technical Support Engineer
    Jama Software
    ------------------------------



  • 7.  RE: Diagram Editor not fully WYSIWYG

    Posted 7 days ago
    Hi Dana,
    I am experiencing the same problem Sophie is facing: you create or edit a diagram and when the editor is left, the image (Jama automatically generates an image of the diagram) looks different, especially that the font and spacing of text is slightly different than in the editor.

    ------------------------------
    Sebastian
    Requirements Engineer
    Sick AG
    ------------------------------



  • 8.  RE: Diagram Editor not fully WYSIWYG

    Posted 6 days ago
    Hi Sebastian,
    Unfortunately, this defect is still present in Jama Connect and it doesn't look like there is a plan on the roadmap to fix it in the near future. I apologize for any frustrations this may be causing you and your team.

    ------------------------------
    Dana Medhaug
    Technical Support Engineer
    Jama Software
    ------------------------------