Support

Expand all | Collapse all

Relations not displaying

Jump to Best Answer
  • 1.  Relations not displaying

    Posted 02-20-2017 12:05
    I just stated populating relations with a custom import. My first test/trial worked flawlessly, but when I attempted this on an actual project, the relations imported but are not visible in list view. The red icon indicating a missing relation is not their either. If I select a requirement and click on the relations icon to the left (which does show a count), the relation is displayed.  To confuse matters, the first requirement does display the relation.

    Any idea why I don't see the relation in the list view?

    ------------------------------
    Jeff Abbott
    Leidos
    Orlando FL
    407-243-3760
    ------------------------------


  • 2.  RE: Relations not displaying

    Posted 02-21-2017 13:30
    Hi Jeff,

    Can you clarify what you mean when you say the relations are missing in List View? From what I understand you linked together items using the Relationship Import Plugin. Where are you expecting to see the relationships in List View?

    ------------------------------
    Kristina King
    Jama Software
    ------------------------------



  • 3.  RE: Relations not displaying

    Posted 02-22-2017 05:43

    I'm relating Capabilities to requirements. I expected to see the ID of the related Capability, but instead a dash "-" is displayed for all items except the first one.  I have attached two screen shots so you can see what I am seeing.  The first if the list view. The second is an individual requirement with relations displayed below.  Note in the second screen shot that "Capability" is blank, but the proper relation is shown below.

    Jeff



    ------------------------------
    Jeff Abbott
    Leidos
    Orlando FL
    407-243-3760
    ------------------------------



  • 4.  RE: Relations not displaying

    Posted 02-22-2017 06:02
    Jeff, 

    Your capability coloumn displays the value of the capability field in your requirement which is empty according to your first screenshot.
    It does not display the id of your downstream capability.

    Anna

    ------------------------------
    Anna Henke
    MeVis BreastCare GmbH & Co. KG
    ------------------------------



  • 5.  RE: Relations not displaying

    Posted 02-22-2017 06:35
    Hmmm, the Capability field is a picklist from the Software Capability item type.  I have attached both the field definition and the item type.

    Note the list view does show the first imported capability, but not the others.

    Jeff

    ------------------------------
    Jeff Abbott
    Leidos
    Orlando FL
    407-243-3760
    ------------------------------



  • 6.  RE: Relations not displaying

    Posted 02-22-2017 06:55
    Can I assume no field is required for downstream items?

    ------------------------------
    Jeff Abbott
    Leidos
    Orlando FL
    407-243-3760
    ------------------------------



  • 7.  RE: Relations not displaying
    Best Answer

    Posted 02-22-2017 09:56
    Correct.
    Consider a relation as a directed link between two objects: A → B. A is upstream of B, B is downstream of A. The → is the relation or trace. 
    Don't consider related items to be somehow encapsulated in other items. 

    Does this help? 

    Anna 

    ------------------------------
    Anna Henke
    MeVis BreastCare GmbH & Co. KG
    ------------------------------



  • 8.  RE: Relations not displaying

    Posted 02-22-2017 11:33
    Yes, thanks very much.

    ------------------------------
    Jeff Abbott
    Leidos
    Orlando FL
    407-243-3760
    ------------------------------