Support

Expand all | Collapse all

Assignee field not showing on exported text run

  • 1.  Assignee field not showing on exported text run

    Posted 09-02-2021 13:17
    Hi,

    We are seeing that when exporting test run, some of the assignees are not showing up in the exported excell file.

    I found the exact same discussion here Support but do not see any comments/suggestions.  I didn't want to comment since the post is almost a year old.

    Do you have any suggestions on how to resolve this?

    Thanks,
    Martha

    ------------------------------
    Martha Fiske
    ------------------------------


  • 2.  RE: Assignee field not showing on exported text run

    Posted 09-02-2021 13:27

    Hi Martha,

    Thank you for reaching out. It looks like that other post was shared as a Library entry rather than a discussion so I'm glad you've posted this as this new discussion.

    It may be helpful to see a copy of your exported report in comparison to the assignee information that is displaying in your instance. To do that, we may want to move this conversation to a Support ticket HERE 

    Please let me know if you have any questions. 



    ------------------------------
    Decoteau Wilkerson
    Jama Software
    OR
    ------------------------------



  • 3.  RE: Assignee field not showing on exported text run

    Posted 09-02-2021 13:33
    Hi Decoteau,

    Thanks for the quick response.  If you look at the attachments that are on the link that I gave you - that's exactly what's happening. If you prefer for me to send you my my reports, let me know and I will get the to you.

    Thanks,
    Martha







  • 4.  RE: Assignee field not showing on exported text run

    Posted 09-02-2021 16:16

    Hi Martha,

    Thanks! Ok, so in that example, there is one user's name being displayed but all other names are left out. In your instance, how many users are being left out? Is consistently one or more users who are being left out?

    Next, I think I've found a related incident in which Test cases with existing Assigned To name forwards the name to Test Run but don't export from Test Run. Essentially, when you create a Test Run from a Test Case with an existing Assigned To name the name will transfer to the Test Run but the Assigned To name will not export to a report.

    To fix this, the name will need to be reset/reassigned in the Test Run in order for it to export successfully.

    Can you verify if those Assigned To fields were filled out before the Test Run was created? Can you try re-assigning one of your Test Runs and let me know if that helps? 



    ------------------------------
    Decoteau Wilkerson
    Jama Software
    OR
    ------------------------------



  • 5.  RE: Assignee field not showing on exported text run

    Posted 09-17-2021 08:15
    Hi Decoteau,

    Sorry for the delayed response.  Here is what I received from our QA people:

    I do have an answer to one of the questions, the Assigned To fields were filled out before the Test Run was created. We have been using this collection of test cases for over 2 months and Test Runs have been created once or twice a week.

    Is there a method to reset and re-assign the Assigned To fields via a script? There are at least 300 - 400 test cases that will need the reset / re-assign to be able to collect accurate metrics from a test run.

    I acknowledge that a reset and re-assign is the present workaround. Are there any plans to fix this issue permanently or are we suppose to simply live with this?

    Thanks,
    Martha



    ------------------------------
    Martha Fiske
    ------------------------------



  • 6.  RE: Assignee field not showing on exported text run

    Posted 28 days ago
    Hi Martha,

    There isn't an API call to assign/un-assign Test Runs.

    However, you can Batch Edit the assignee field from the Test Center.  Saving the assignee may fix the issue.



    If this issue persists, we need to look into why this happens:

    - What's your Jama version?
    - When the export is done to Word, is it the same result?
    - Do all Test Runs belong to the same Project?

    ------------------------------
    Decoteau Wilkerson
    Jama Software
    OR
    ------------------------------



  • 7.  RE: Assignee field not showing on exported text run

    Posted 26 days ago
    Hi Decoteau,
    I have confirmed that the name is populated in the excel sheet if the name is reentered on the test case.
    This also happens for the Word document.

    I will batch update the assignees on the test cases.  Do we need to continually look for this and update any time we see the problem?

    Let me know if you need anymore information from us.

    Thanks,
    Martha Fiske

    ------------------------------
    Martha Fiske
    ------------------------------



  • 8.  RE: Assignee field not showing on exported text run

    Posted 24 days ago

    Hi Martha, 

    Thank you for your patience! We have filed a defect for this issue. I'm sharing that information for your reference:

    SOS-DEF-5563 - Test Center / Export: Test Cases with existing Assigned To user names forwards the name to Test Run but doesn't export from Test Run 

    The workaround is: user name will need to be reset/reassigned in the Test Run in order for it to export successfully. This can do this through Batch Edit.

    You can check future release notes for this ID to see if this bug has been fixed.

    Please let me know if you have any questions! 


    ------------------------------
    Decoteau Wilkerson
    Jama Software
    OR
    ------------------------------