Support

Expand all | Collapse all

Moving requirements into a release

  • 1.  Moving requirements into a release

    Posted 12-05-2019 11:19
    ​​The quickest way to bulk move a set of requirements into a release is to select all from a list of the requirements, then drag and drop them into the release.  I have about 380 requirements in the set.  Sometimes it works, often it does not.  When it does not I get the following type of error, "Item with ID "62" does not exist."  So then I move them one page at a time.  Sometimes that works and sometimes it doesn't.  I have deselected requirements on the page one by one to see if a specific requirement is the problem.  I'll get the same error.  Then I'm stuck editing each requirement one by one and updating the Release field to the release of interest.

    How can I move the bulk set of requirements into the release without all this hassle?

    ------------------------------
    Art Stone
    Boeing
    714-580-9042
    ------------------------------


  • 2.  RE: Moving requirements into a release

    Posted 12-05-2019 12:14
    Hi Art

    Here in Jama Support, we see this error regularly when a project clean up and project reindex are needed:
    Index Project Items
    Project Cleanup
    This can be done with both Cloud and Self Hosted customers. Both actions wont result in any downtime and no information will be removed in the process. Can you let us know if this worked for you? If not, please submit a support ticket so our team can take a closer look at your companies instance. We can then share the results here without giving away any of your companies private information possibly shared in the private support ticket.

    Thank you

    ------------------------------
    Godiva Hunt
    ------------------------------



  • 3.  RE: Moving requirements into a release

    Posted 12-05-2019 15:30

    Hi Godiva,

     

    I ran the "Index Project Items" and "Project Cleanup" and then attempted to move 380 requirements into the release folder, with the same results.  The 380 requirements list is split across 8 pages.  My next attempt was to just select one page of requirements and move them, and it worked.  I tried again on the next page and it failed.  So I selected about half the requirements on that page and moved them successfully.  I am able to repeat that reliably.  From my perspective it appears to be Jama problem.  Select  more than 40 requirements for a move to the release folder and Jama generates an error.  It would be a real time saver if I could just move the whole requirements set at once.

     

    Thanks, Art