Support

Expand all | Collapse all

Report parameter of type boolean not populated to velocity scripts

  • 1.  Report parameter of type boolean not populated to velocity scripts

    Posted 11-12-2019 00:01

    Hi,

    while testing the new velocity in Jama 8.42 we noticed that boolean parameters are not being populated into the velocity scripts.
    How to reproduce: Create a velocity script with the following content:

    <html>
    <body>
    Release Parameter: $releaseParam <br>
    Location Parameter: $locationParam <br>
    Baseline Parameter: $baselineParam <br>
    String Parameter: $stringParam <br>
    Date Paramter: $dateParam <br>
    Boolean Parameter: $boolParam <br>
    Testplan Paramter: $testplanParam <br>
    Review Paramter: $reviewParam <br>
    </body>
    </html>

    Upload the template to Jama with the following settings:



    Run the report and chose parameters for each of the same.

    Regardless of what has been chosen for the Bool Parameter, the output in the report is
    Boolean Parameter: $boolParam
    So the parameter cannot be evaluated in the script.

    If this is a reproducible behaviour on your side please let us know the issue-number. We may be able to work around this by using another report parameter type, but we would rather not do it if a fix is provided.

    Thank you,
    Anna



    ------------------------------
    Anna Henke
    MeVis BreastCare GmbH & Co. KG
    ------------------------------


  • 2.  RE: Report parameter of type boolean not populated to velocity scripts

    Posted 11-12-2019 08:17
    @Anna:

    Thank you, just wanted to reach out. In the case of this particular Velocity question; your best avenue is to make a Support ticket with our internal system. We can get the right eyes on it and escalate it accordingly that way. I will circle back to this thread and put any relevant answers after the ticket closes.

    Anna, Ill look out for that ticket!

    Best,

    ------------------------------
    Chloe Elliott
    Jama Software
    Portland OR
    ------------------------------



  • 3.  RE: Report parameter of type boolean not populated to velocity scripts

    Posted 11-14-2019 13:40
    Thanks for putting in that ticket Anna, just completing the circle here for anyone else who may be experiencing the same behavior.

    We are able to reproduce the behavior you are experiencing and can confirm that it is a defect. 

    This bug has been logged in our internal system with this ticket and your organization associated to it. For your reference, I have added the bug ID, SOS-DEF-4509, to the Jama Key field of this ticket. You can check future release notes for this ID to see if this bug has been fixed.

    Best,

    ------------------------------
    Chloe Elliott
    Jama Software
    Portland OR
    ------------------------------