Support

Expand all | Collapse all

Error message on opening filter in project after update

  • 1.  Error message on opening filter in project after update

    Posted 16 days ago
    Edited by Florian Giller 16 days ago
    We recently updated from 8.42.1 to 8.49.1.
    When opening a specific filter, this error popup occur:
    A Search Service error occurred, exception class: 
    SearchRuntimeException with no message available. 
    See Search Service logs for more detail. Response object:
    InboundJaxrsResponse{context=ClientResponse{method=POST, uri=http://172.17.0.1:7500/contour/ContourItem/_search, status=400, reason=Bad Request}}​

    Unfortunately I cannot edit the filter to see the used settings.
    I attached screenshots of the filters to the post.

    Where can I find the "Search Service logs"?
    What can we do to resove this issue?





    ------------------------------
    Florian Giller
    Panasonic Industrial Devices Europe GmbH
    Lüneburg
    ------------------------------


  • 2.  RE: Error message on opening filter in project after update

    Posted 16 days ago

    Hi Florian,

    Thank you for reaching out! We have come across a similar issue before and found that a Full Reindex corrected it. Can you please try and let me know if that works? 

    Also, you can find the search log at /logs/search/jamasearch.log

    Please let me know if you have any questions. 

    Best, 



    ------------------------------
    Decoteau Wilkerson
    Jama Software
    OR
    ------------------------------



  • 3.  RE: Error message on opening filter in project after update

    Posted 15 days ago
    Hi Decoteau,
    thanks for your help.

    I inspected the XML of the filter and found an empty smartFilterQuery element:
                        <smartFilterQuery name="">
                            <filterRule operator="2" id="0" parentId="" docType="">
                                <filterRule operator="1" id="1" parentId="0" docType="">
                                    <filterRule operator="1" id="2" parentId="1" docType="0" />
                                </filterRule>
                            </filterRule>
                        </smartFilterQuery>
    After this part has been removed, the filter works correctly again.

    ------------------------------
    Florian Giller
    Panasonic Industrial Devices Europe GmbH
    Lüneburg
    ------------------------------



  • 4.  RE: Error message on opening filter in project after update

    Posted 15 days ago
    Hi Florian,

    Thank you for the update! I happy to hear that you found this solution!

    Best,

    ------------------------------
    Decoteau Wilkerson
    Jama Software
    OR
    ------------------------------