Support

1.  Test Runs - Review Center Reading View Bug

Posted 14 days ago
Hi,

We are trying to send to various Test Runs to review center for external review, but are frustrated by how the content displays in Review Center Reading View.  While you can see the test steps, test case, and test group it says "Not available for reviews" next to Test Cycle.

However, in single item view, this information becomes available. (see screenshots)

This is a problem for us because many times the same validation will be run many times, and the Test Cycle is how we distinguish between each validation test.

e.g. Test Run = Install Pilot OBE in CDOT Fleet Vehicles
- Test Cycle 1: License Plate XXXXXX
- Test Cycle 2: License Plate XXXXXX
- Test Cycle 3: License Plate XXXXXX


We need to be able to see Test Cycle in Review Center Reading View. Is this a bug? Please review the screenshots and let me know.

------------------------------
Bolling Starke
Denver CO
3343223002
------------------------------


2.  RE: Test Runs - Review Center Reading View Bug

Posted 13 days ago
Hello Bolling,
Will you also attach screenshots showing the configuration of the 2 custom fields "Test Plan" and "Test Cycle"? Also, where are you getting the URL in the Test Cycle field, does it link to the Test Cycle?



------------------------------
Dana Medhaug
Technical Support Engineer
Jama Software
------------------------------



3.  RE: Test Runs - Review Center Reading View Bug

Posted 11 days ago
Hi Dana,

What we are trying to display in the review is various Test Runs associated with different Test Cycles (and thus will have different results) all tagged with the same "Release". We created a custom field for release "release3", but the fields for "testCycle" and "testPlan" are predefined fields on the Test Run artifact. One thing I forgot to note is that when trying to access the review, we are initially given the error "Cannot read property 'update' of null".

I've attached screenshots showing the field config of our Test Run artifact, the config of the Filter that we sent for review, the error that is thrown upon accessing the review. as well as screenshots from the single item view showing that Test Cycle and Test Field link to Jama items and are functional in Single Item View. Please let me know if you need any additional information.

Thanks


------------------------------
Bolling Starke
Denver CO
3343223002
------------------------------



4.  RE: Test Runs - Review Center Reading View Bug

Posted 9 days ago
Bolling,
Thank you for the added information. The error you see (cannot read property 'update' of null) when you go into the Review is a known defect (SOS-DEF-2454) which occurs when viewing Test Runs in the Review Center. The other issue you are reporting looks like a new defect and I am able to reproduce it in my hosted instance. The Test Cycle field is visible in single item view but not in the reading view. I will relate Panasonic to the known issue and when I get done filing the new defect I will relate you to that one as well.

------------------------------
Dana Medhaug
Technical Support Engineer
Jama Software
------------------------------



5.  RE: Test Runs - Review Center Reading View Bug

Posted 6 days ago
Hi Bolling,
I filed a new defect for the Test Cycle field not showing in reading view in the Review center. I also related Panasonic to the defect. For your records, the defect is SOS-DEF-2463.

------------------------------
Dana Medhaug
Technical Support Engineer
Jama Software
------------------------------