Support

Expand all | Collapse all

Pass with Errors -> configuring item type

  • 1.  Pass with Errors -> configuring item type

    Posted 5 days ago
    Hi,
    Pass with errors is fairly new feature for me (as if the whole Jama wasn't :) I read a discussion about filtering results, but I am wondering about the field. Is this Pass with errors a automatic field in Test run Item type? My preceeder may have altered it and I'm puzzled, how it should be.

    The main need is to get all the test runs passed with errors filtered.

    ------------------------------
    Mari Leipola
    Project assistant
    Finland
    ------------------------------


  • 2.  RE: Pass with Errors -> configuring item type

    Posted 4 days ago
    Edited by Chloe Elliott 4 days ago
    Mari:

    The "Pass with Errors" field is a predetermined field but, it can be edited out of the item, or the name could be changed. My first question is, have you checked the Test Run item type to see if this field is still enabled?


    Perhaps the name was changed? When you look at the Test Run item type in the Admin panel, see above Admin>Item type>Test Run>Fields, do you see any "Flag" field types? I didn't see a way to edit the Unique Field Name when I looked so, it should have the unique field name of "forcePassed".

    Another way I would check is to run an Advanced Filter and see if it is pulling items from this field appropriately.

    Mari, could you explain what behavior you are seeing which is making you suspect this was altered?

    Looking forward to hearing back,

    ------------------------------
    Chloe Elliott
    Jama Software
    Portland OR
    ------------------------------



  • 3.  RE: Pass with Errors -> configuring item type

    Posted 4 days ago
    Cheers Chloe!

    I checked from Item types and we have this field forcePassed, but the visible name was changed. The problem is that I don't get any results when using filter even though this feature has been used. But the problem lies apparently somewhere else. I'll continue with troubleshooting :)

    ------------------------------
    Mari Leipola
    Project assistant
    Finland
    ------------------------------



  • 4.  RE: Pass with Errors -> configuring item type

    Posted 3 days ago
    Edited by Chloe Elliott 3 days ago
    Mari:

    Interesting, I did test changing the field name to see if this effected my filtering, and it did not.

    Are you attempting to filter past versions of the Test Run which have previously been "Passed with Errors"? I know I don't have my Test Management area configured exactly as yours but, I noticed that I was only able to pick up the most recent version of "Passed with Errors" in the Advanced Filter. When I would rerun the Test Run and then "Pass" it, that individual Test Run would disappear from my filter.

    It could be that you do not have any current version Test Runs who have this status? Your thoughts?

    Best,

    ------------------------------
    Chloe Elliott
    Jama Software
    Portland OR
    ------------------------------



  • 5.  RE: Pass with Errors -> configuring item type

    Posted 2 days ago
    Thanks Chloe!

    I got my filter to work, thank you! I guess it had something to do with the bug of test runs in another project than used test cases. Maybe, but all in all, now it works!

    ------------------------------
    Mari Leipola
    Project assistant
    Finland
    ------------------------------